Install

Install Scapix

$ git clone https://github.com/scapix-com/scapix

Supported host platforms

  • macOS
  • Windows x64
  • Linux x64 (Ubuntu 18.04 x64 or compatible)

Requirements

Tested C++ compilers

ObjC/Swift bridge:

  • Clang 6 or later (possibly earlier).

Java bridge:

  • Clang 6 or later (possibly earlier).
  • GCC 8.1 or later.
  • MSVC vs2019 or later.

Python bridge:

  • Clang 6 or later (possibly earlier).
  • GCC 7.1 or later (possibly earlier).
  • MSVC vs2017 or later (possibly earlier).